Flowdock is experiencing degraded performance.
Incident Report for Flowdock
Resolved
We have resolved the performance-related problems. We will continue to monitor performance and availability.
Posted Mar 23, 2020 - 04:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 23, 2020 - 01:28 UTC
Investigating
We are currently investigating the issue.
Posted Mar 22, 2020 - 15:08 UTC
This incident affected: App and Network.