Flowdock down
Incident Report for Flowdock
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 13:57 UTC
Investigating
We are currently investigating an issue with Flowdock showing a "page not found" error when trying to access. We apologize for the inconvenience and will update when we have restored service.
Posted Apr 21, 2020 - 13:45 UTC
This incident affected: App.