Flowdock experiencing issues
Incident Report for Flowdock
Resolved
Resolved! Thanks for your patience, and please continue to enjoy Flowdock!
Posted about 1 month ago. Sep 15, 2017 - 21:16 UTC
Investigating
We are currently experiencing issues with Flowdock and are working quickly to resolve the issue. We apologize for this inconvenience.
Posted about 1 month ago. Sep 15, 2017 - 21:07 UTC