Issues in message delivery
Incident Report for Flowdock
Resolved
Systems have recovered and message delivery is back to normal.
Posted about 2 years ago. Oct 13, 2015 - 19:32 UTC
Investigating
There are currently issues in message delivery, we're looking into it.
Posted about 2 years ago. Oct 13, 2015 - 19:19 UTC