File Uploads Down
Incident Report for Flowdock
Resolved
Flowdock's file storage is now up.
Posted 10 months ago. Feb 28, 2017 - 21:00 UTC
Investigating
Our file upload process is presently broken due to issues with Amazon S3. We will be monitoring the situation and provide updates as they are available.
Posted 10 months ago. Feb 28, 2017 - 18:03 UTC