Flowdock Performance Issues
Incident Report for Flowdock
Resolved
This incident has been resolved.
Posted 3 months ago. May 11, 2017 - 14:22 UTC
Investigating
We are currently investigating issues with slow page load times and degraded performance.
Posted 3 months ago. May 11, 2017 - 14:02 UTC