Slowness in the service
Incident Report for Flowdock
Resolved
The service is operating normally again. Sorry about that!
Posted almost 2 years ago. Sep 17, 2015 - 19:09 UTC
Identified
There's still slowness in the service related to earlier outage. We're working on fixing it.
Posted almost 2 years ago. Sep 17, 2015 - 18:55 UTC